PostgreSQL Error 28000: invalid_authorization_specification — настройка pg_hba.conf
Устранение ошибки авторизации PostgreSQL 28000: настройка pg_hba.conf, исправление методов аутентификации md5/scram-sha-256 и прав пользователя....
PostgreSQL Error 40P01: deadlock_detected — поиск и устранение дедлоков
Диагностика взаимоблокировок PostgreSQL 40P01 deadlock_detected: настройка deadlock_timeout, log_lock_waits, анализ графа дедлока в 1С и СУБД....
PostgreSQL Error 40001: serialization_failure — устранение конфликтов транзакций
Устранение ошибок сериализации PostgreSQL 40001 (could not serialize access due to concurrent update): логика retry, уровни изоляции Repeatable Read и...
PostgreSQL Error 53400: configuration_limit_exceeded — диагностика лимитов
Как устранить ошибку PostgreSQL 53400 configuration_limit_exceeded: переполнение max_locks_per_transaction, max_pred_locks_per_transaction и лимитов с...
PostgreSQL Error 53300: too_many_connections — пулинг через PgBouncer
Как решить проблему исчерпания соединений PostgreSQL 53300 (too_many_connections): тюнинг max_connections, внедрение PgBouncer и оптимизация пула rpho...
PostgreSQL Error 53200: out_of_memory — расчет work_mem и shared_buffers
Устранение ошибки PostgreSQL 53200 out_of_memory: балансировка work_mem, maintenance_work_mem, защита от исчерпания RAM при пиковых подключениях 1С....
PostgreSQL Error 53100: disk_full — исправление переполнения диска
Как восстановить работу PostgreSQL при ошибке 53100 disk_full: безопасная очистка pg_wal, удаление временных файлов pg_tblspc/pgsql_tmp и автовакуум....
PostgreSQL Error 57014: query_canceled — Statement Timeout и Lock Timeout
Диагностика отмены запросов по таймауту в PostgreSQL (SQLSTATE 57014): настройка statement_timeout, lock_timeout, idle_in_transaction_session_timeout....
PostgreSQL Error 57P03: the database system is starting up / cannot_connect_now
Устранение ошибки PostgreSQL 57P03: отслеживание прогресса стартового восстановления (Starting Up), настройка реплик в Standby и ускорение Checkpoint....
PostgreSQL Error 57P02: crash_shutdown — аварийное падение и отладка
Как расследовать аварийное завершение PostgreSQL с кодом 57P02: падение дочерних backend-процессов, сигналы SIGSEGV/SIGBUS, OOM Killer и процедура Cra...
PostgreSQL Error 57P01: admin_shutdown — причины и восстановление
Диагностика ошибки PostgreSQL 57P01 admin_shutdown: анализ pg_terminate_backend, плановая остановка кластера, разрывы соединений в 1С и пулерах PgBoun...
MSSQL Error 49930: Log writer performance degraded on drive containing LDF
Устранение деградации производительности Log Writer (ошибка 49930) в MSSQL: задержки WRITELOG, виртуальные файлы журнала (VLF) и перенос LDF на быстры...